Platoon Custom Emblem upload problem - Better Battlelog Forums #1978

On two different PC setups (which have both worked up until this last weekend), whenever I Click edit platoon emblem, then click the yellow button to upload image (and indicate the image that I want uploaded... just as I have done almost weekly for months now), the timer will tick down as b4 as if it is uploading the image............. and the image........... never......... uploads!
I have reinstalled Chrome, I have reinstalled BBlog, I have reinstalled/updated the Jscript, it still looks like it wants to upload but just sits there turning around and around and around and around and nothing gets uploaded.
Try smaller images, for example max. 450x450 or 350x350.
Maybe you are using a too big image that BBLog/Battlelog can't save.
Thanks... BUT... Tried that too. The image I couldn't load, I had some else load (easily). One I had loaded before... won't load again.
[the biggest I have loaded previously has been around 400x400, PLUS I have Business class cable... so it is not slow]
Hm. Weird. Maybe you can try firefox? For me its working on both browser correctly.
Firefox was my next choice as well. But I am one of those that likes to fix problems. I hate to give up on one till I figure it out... then I go to something else, like Firefox in this case. Hahahaha. I know... I'm weird.
Yes, to fix the problem i need to know whats the problem is.
When it's working for you on FF i can search more accurate for a bug.
Firefox does not show upload emblem button
I've tried both FF and Chrome, 320x320 .png and .jpeg, never stops uploading. You can still edit using the Battlelog objects, but will not upload pics.

*edit - this worked, thanks Jumpy.
Can anyone of you post the graphics you want to upload?
I done a lot of test and it works everytime.
I uninstalled Chrome and all Flash, Shockwave etc. on one laptop setup. Installed Firefox. Reinstalled Better Battlelog and Java and Adobe and I got this setup to work. Attempted the same on my other laptop (one I was at yesterday for most of posts above) and I still don't get the upload image button to appear (in Firefox as it was in Chrome).
Last thing i can say is: Have you enable the "Minor Improvements" Option? If not the button will not shown.
A fix should be in the next bblog release 2.4.0.
Problem fixed itself and then lately stopped working again (past week) on both PC's.