Problem with uploading platoon image. - Better Battlelog Forums #91571

Post edited 2 x times, last by
Hello all!
I have problem with uploading a platoon image. I enabled uploading platoon image in settings in bblog. When im uploading a new platoon picture, i`m directed to platoon site, without changing the image. Image is in right sizes 320x320, and it weight about 50kb. I can`t click "save" in image settings on editing platoon image.
I uploaded picture once, but after that i changed it, and i can`t change it back. I was trying many times to upload a diffrent image, but still nothing happens. I see the "old" picture - only me see this. My friends see the normal emblemat. I tried to reinstall bblog, but this didnt help me. Changing emblemat withouth bblog, and after that trying to upload a new one pic didn`t help. I have no ideas what this happens.

Im using firefox ( latest version) and bblog 3.4.0 (latest version).

Thanks for help, and sorry for my english!
Once you have uploaded a image it's cached for about 3 hours since last access.
So, clear your cache or wait some time.
Post edited 1 x times, last by
I tried this. I waited one night, but this didnt help me. Cleaning caches didnt help me to.
post your platoon link, the image you see and the image you expect to see.
- platoon
- this is image what i see ( first image)

and the same image i want to see. but my friends see only normal emblemat.

I changed it for another picture, but i changed it back. And noone see this picture.
I see that on the platoon page
And your friends must also enable bblog and the upload feature, otherwise they don't see a emblem.
All is described here detailed

No bug at all, please read the FAQ.
Post edited 1 x times, last by
So , if they dont have bblog they can`t see my platoon image?

This is in FAQ. Thanks for help. Topic can be closed.